Trucos Excel. Tranformar un caracter a fecha

Si tenemos en Excel celdas con valores en la forma: viernes 1 de enero de 2010 sábado 2 de enero de 2010 domingo 3 de enero de 2010 … y deseamos transformarlo en fecha podemos hacer lo siguiente: =TEXTO(IZQUIERDA(EXTRAE(A2;ENCONTRAR(” “;A2;1)+1;30);2)&EXTRAE(EXTRAE(A2;ENCONTRAR(” “;A2;1)+1;30);6;4)&DERECHA(EXTRAE(A2;ENCONTRAR(” “;A2;1)+1;30);4 );”dd/mm/aaaa”)*1 ¡Toma función! Vamos a contar paso por paso como funciona:  necesitamos 1 […]

Leer más
Truco SAS. Macro buscar y reemplazar en texto

A veces hay problemas a la hora de importar un fichero de texto a SAS. Por ejemplo el fichero proviene de Access y tiene los números con formato europeo. El siguiente programa hace un buscar y reemplazar pero con SAS. Partimos de un fichero de texto ubicado en c:\temp\pepin.txt así: 4.497,31 2.776,50 2.555,46 6.782,73

Leer más
Importar a SAS desde otras aplicaciones.

Una de las labores más comunes con SAS consiste en leer e importar ficheros provenientes de otras aplicaciones. Es muy habitual trabajar con tablas de Excel, Access, Lotus, Business Object, Microstrategy, SQL Server, SAP… Para ello SAS dispone de algunos módulos que no se disponen en todas las instalaciones debido a que pueden encarecer mucho […]

Leer más